Построение модели оптимального распределения ресурсов


Лабораторная работа № 1

Построение модели оптимального распределения ресурсов


Значительное число задач в экономике можно рассматривать как задачи распределения ресурсов. Действительно, если финансы, сырье, оборудование и даже людей считать ресурсами, то задачи, которые рассматривают оптимальное распределение ресурсов, занимают особое место.


Постановка задачи


Фабрика имеет в своем распоряжении определенное количество ресурсов: рабочую силу, сырье и финансы.

Требуется определить, в каком количестве нужно выпускать продукцию четырех типов П1, П2, П3, П4 для получения максимальной прибыли. Количество ресурса каждого вида, необходимое для выпуска единицы продукции данного типа, называется нормой расхода. Нормы расхода и прибыль, получаемая от реализации единицы каждого типа продукции, наличие ресурса, приведены в таблице 1.


Таблица 1

РесурсП1П2П3П4наличие ресурсаприбыль6070120130-Трудовые ресурсы111116Сырье6543110Финансы461013100

Модель.

Введем следующие обозначения:

- количество выпускаемой продукции -го типа ;

- количество располагаемого ресурса -го вида ;

- норма расхода -го ресурса для выпуска единицы продукции - го типа;

- прибыль, получаемая от реализации единицы продукции -го типа.

Таким образом, требуется максимизировать значение целевой функции



при ограничениях по ресурсам


.


При заданных параметрах нашей задачи (Табл. 1) имеем

·целевая функция (1)

·ограничения


(2)

задача excel производственный прибыль

где левая часть представляет выражение для величины потребного ресурса, а правая - количество имеющегося ресурса.

Технология решения задачи с помощью Поиска решения Excel

Задачи на поиск максимума или минимума целевой функции при ограничениях, накладываемых на независимые переменные, называются оптимизационными. Подобные задачи в Excel решаются с помощью надстройки Поиск решения.

Для решения задачи сначала, как правило, создается форма для ввода условий. В эту форму вводятся исходные данные, зависимости для целевой функции (ЦФ) и ограничений, а также параметры для решения задачи.

Создайте форму для ввода данных в соответствии с Рис.1.


Рис. 1. Форма для ввода данных. Ячейка для целевой функции выделена.


Оптимальные значения вектора будут размещаться в ячейках C3:F3, в то время как оптимальное значение целевой функции (ЦФ) - в ячейке G4 (на рисунке для наглядности эта ячейка выделена).

Для проведения расчета введите в ячейку G4 зависимость для целевой функции =СУММПРОИЗВ(C3:F3;C4:F4) (см. формулу (1)).

Введите в ячейки G7:G9 зависимости для левых частей ограничений (см. (2)) в соответствии с приведенной ниже таблицей


ЯчейкаФормулаG7=СУММПРОИЗВ(C3:F3;C7:F7)G8=СУММПРОИЗВ(C3:F3;C8:F8)G9=СУММПРОИЗВ(C3:F3;C9:F9)

Запустите Поиск решения и введите ограничения в соответствующем окне диалога (Рис. 2)

Рис.2. Ввод ограничений для решения задачи.


Установите требуемые для решения задачи параметры в окне диалога Параметры поиска решения - Линейная модель и Неотрицательные значения.

Решите задачу с помощью запуска Поиска решения.


Самостоятельное задание 1


Предположим, что руководство фабрики может в определенных пределах изменять количество имеющихся ресурсов всех видов. Определите, как сильно влияют возможные изменения запасов на величину целевой функции

1.Последовательно изменяя запасы трудовых ресурсов (16,17, …, 25) проанализируйте зависимость целевой функции. Остальные ресурсы (сырье и финансы) считайте неизменными. Постройте график

2.Аналогично, изменяя запасы сырья (110, 120, …, 150) при неизменных трудовых и финансовых ресурсах, оцените прибыль. Постройте график

.Проделайте аналогичные операции с величиной финансовых ресурсов (100, 110, …, 200) и также постройте график.

Изменение какого ресурса (в условиях данной задачи) наиболее существенно сказывается на величине прибыли?


Самостоятельное задание 2


Руководство предприятия рассматривает три варианта производственной программы с целью отбора наиболее эффективного с точки зрения прибыли. Каждый из вариантов характеризуется своей целевой функцией и системой ограничений. Не конкретизируя тип выпускаемой продукции и ресурсы, задача формулируется следующим образом

вариант:



вариант



вариант


Определите наиболее выгодный для предприятия вариант производственной программы.


Теги: Построение модели оптимального распределения ресурсов  Практическое задание  Менеджмент
Просмотров: 8799
Найти в Wikkipedia статьи с фразой: Построение модели оптимального распределения ресурсов
Назад